Reply To: API not sticking

Forums General API not sticking Reply To: API not sticking

#388
Jason Caldwell
Participant

Deprecated: wp_make_content_images_responsive is deprecated since version 5.5.0! Use wp_filter_content_tags() instead. in /nfs/c09/h02/mnt/138233/domains/s2member.net/html/wp-includes/functions.php on line 4777

Definitely looks like a Google Chrome Autofill problem to me. The yellow highlight in those fields is triggered by Autofill in Google Chrome. So you are entering and saving the details that you want, but whenever the page loads back up, the previous values are being cleared in favor of Autofill values. That’s what the yellow highlight is there to indicate—in Google Chrome.

The other question too is why it would display one thing in my Chrome browser and not in others. In that case, which one was the actual setting that was enforced?

Because the values that you entered and submitted are in fact being saved as expected; i.e., what you entered is what is being submitted and saved by s2Member as your configured option values. Loading that up in another browser shows what s2Member actually has. However, in Google Chrome, because you have Google Autofill enabled (which is quirky and persistent to a fault), you are seeing yellow backgrounds with autofill values. Autofilled by your browser instance only, not what s2Member actually has.

With the autofilled (yellow background) values, if you then submit the form again (with those autofill values), you override what s2Member was supposed to have. So it can lead to confusion and bad config values.

Unfortunately, Google Chrome Autofill is overly persistent. I’m not aware of a way to prevent this. We already set autocomplete="off on both the <form> tag and on each <input> tag. Google Chrome Autofill should be obeying those, but it’s famous for not doing so. So I suggest upgrading to the latest release of Chrome to see if that clears this up. If the problems persist, try disabling Autofill. See instructions here: https://support.google.com/chrome/answer/142893?hl=en