API not sticking

Forums General API not sticking

Tagged: ,

Viewing 18 posts - 1 through 18 (of 18 total)
  • Author
    Posts
  • #366
    Carole Asselin
    Participant

    Deprecated: wp_make_content_images_responsive is deprecated since version 5.5.0! Use wp_filter_content_tags() instead. in /nfs/c09/h02/mnt/138233/domains/s2member.net/html/wp-includes/functions.php on line 4773

    Hi, i thought i had seen another forum for users of s2M pro, but i ended up here. If this is the wrong place, please, redirect me to the right place (and if this needs to be on the wp forum, i can copy it there).

    I have had one incident, last week, where the API for MailChimp was changed “accidentally”, and the list ID for Level 4, was changed to my admin username. The length of the API looked like it was my admin password. I changed things and it didn’t come back. However, today, on two other of my sites, i see that the API AND the List ID for level 4 (only that level), are also changed, but i can’t reset them as they keep reverting to the wrong entries.

    Here is a screencast of this: http://screencast.com/t/15rw0bkMRqGr

    Anyone else reported this?
    Right now, all my newly registered members will NOT be transfered to the mailing list (MailChimp in this case).

    #367

    Deprecated: wp_make_content_images_responsive is deprecated since version 5.5.0! Use wp_filter_content_tags() instead. in /nfs/c09/h02/mnt/138233/domains/s2member.net/html/wp-includes/functions.php on line 4773

    So good to have you here! 😀

    Yes, this forum is fine for s2Member Pro or free.

    Thank you for the video, it was very helpful to understand the behavior you are seeing. I haven’t seen other reports like it yet.

    This is just a guess, but maybe LastPass is populating the form as if it were a login or registration one? I see the message at the top of the page and find it odd for that form. Could you test logging out of LastPass and test again?

    I sort of remember a LastPass related problem with the WP user profile edit form recently…

    I’ll ask Jason about this.

    #368
    Carole Asselin
    Participant

    Deprecated: wp_make_content_images_responsive is deprecated since version 5.5.0! Use wp_filter_content_tags() instead. in /nfs/c09/h02/mnt/138233/domains/s2member.net/html/wp-includes/functions.php on line 4773

    I thought of that, but i am using LastPass all the time, while this behavior happens on 2 sites but not on the other. And also, i have been using LastPass for months, yet that behavior only happened recently.

    #369

    Deprecated: wp_make_content_images_responsive is deprecated since version 5.5.0! Use wp_filter_content_tags() instead. in /nfs/c09/h02/mnt/138233/domains/s2member.net/html/wp-includes/functions.php on line 4773

    Yeah, I know it would be very weird, but just to confirm, could you test logging out of LastPass and trying to reproduce that behavior in the form again? It’s just that I can’t think of anything else causing it yet. :/

    Hopefully Jason may have ideas for other things to check.

    #370
    Carole Asselin
    Participant

    Deprecated: wp_make_content_images_responsive is deprecated since version 5.5.0! Use wp_filter_content_tags() instead. in /nfs/c09/h02/mnt/138233/domains/s2member.net/html/wp-includes/functions.php on line 4773

    I logged out of LastPass and tried saving the API again and it is not working any better. I checked the site where the API is now correct (i fixed it last week) and it is still correct.

    On one site that had fewer plugins, i deactivated all of them except for s2M, and it would not help at all. It still does not stick.

    I made another test and put something as a Level3 list ID on a site where i don’t have any; when i saved, it DID save it correctly. So, i am wondering if the API key and the Level4 list ID are using variables that are shared with something else in WP. I thought it might have been the WP version as that one site was not running the latest one, but it still didn’t change anything.

    Let me know if there is anything else i can try to help pinpoint. Right now, i am really stuck as members are not automatically added to my MC list for now.

    #372
    Carole Asselin
    Participant

    Deprecated: wp_make_content_images_responsive is deprecated since version 5.5.0! Use wp_filter_content_tags() instead. in /nfs/c09/h02/mnt/138233/domains/s2member.net/html/wp-includes/functions.php on line 4773

    I ran more tests. I had another admin log in, to see if the admin username and password would change to his. It didn’t. Even weirder, he said the API and level 4 list, looked NORMAL.

    Conclusion: maybe it was my cache. I deleted my cache, and the saved passwords on my Chrome browser: no change: still reverted to the odd info.

    Tried Firefox and IE, and interestingly, they both showed normal API and level 4.

    It looks like it might be a Chrome issue, BUT why does it only affect 2 out of 3 sites?
    Although i see the API and lever 4 list id as wrong, maybe it is right all that time? But how can i know?

    #373

    Deprecated: wp_make_content_images_responsive is deprecated since version 5.5.0! Use wp_filter_content_tags() instead. in /nfs/c09/h02/mnt/138233/domains/s2member.net/html/wp-includes/functions.php on line 4773

    Well done on testing more variables to notice that it’s the browser.

    That’s a very interesting behavior. Yes, it’s very odd that the browser would affect some sites and not others. I don’t know what’s doing it. Maybe one of the extensions? Do you have the same s2Member version in all those different installations?

    I guess that when you see that, you can open Firefox to check what it really is…

    #376
    Carole Asselin
    Participant

    Deprecated: wp_make_content_images_responsive is deprecated since version 5.5.0! Use wp_filter_content_tags() instead. in /nfs/c09/h02/mnt/138233/domains/s2member.net/html/wp-includes/functions.php on line 4773

    Yes, i have the same s2Member version on all of them.

    As far as Chrome extensions, i have Pinterest, LastPass, Share as image and Facebook Pixel Helper. Only those 4.

    The last extension installed was at least a couple of weeks ago and it was the FB pixel helper. So, in case it was the culprit, i removed it from my Chrome browser and tried again. No luck. It still won’t SHOW the correct API.

    As you said, it is possible to check in a different browser, and now, i know it, but then, how many things might not be displaying correctly? And why does it change? And why one site and not the other?

    #379

    Deprecated: wp_make_content_images_responsive is deprecated since version 5.5.0! Use wp_filter_content_tags() instead. in /nfs/c09/h02/mnt/138233/domains/s2member.net/html/wp-includes/functions.php on line 4773

    Yeah, I know what you mean… That’s why I notified Jason, in case it’s something we can pinpoint and do something about to prevent it under whatever rare combination of factors that causes it.

    Here’s something I’d like you to try, if possible… Would you add a list to the levels below 4 even if you’re not using them? I wanna see if skipping one or more in that settings panel, could be related.

    Looking forward to your update. 🙂

    #382
    Carole Asselin
    Participant

    Deprecated: wp_make_content_images_responsive is deprecated since version 5.5.0! Use wp_filter_content_tags() instead. in /nfs/c09/h02/mnt/138233/domains/s2member.net/html/wp-includes/functions.php on line 4773

    Interestingly, that IS working. On both problematic sites.
    Strange that it never did that before. So there might still be a need to investigate to know why it happened in the first place.

    #383
    Carole Asselin
    Participant

    Deprecated: wp_make_content_images_responsive is deprecated since version 5.5.0! Use wp_filter_content_tags() instead. in /nfs/c09/h02/mnt/138233/domains/s2member.net/html/wp-includes/functions.php on line 4773

    The other question too is why it would display one thing in my Chrome browser and not in others. In that case, which one was the actual setting that was enforced?

    #384

    Deprecated: wp_make_content_images_responsive is deprecated since version 5.5.0! Use wp_filter_content_tags() instead. in /nfs/c09/h02/mnt/138233/domains/s2member.net/html/wp-includes/functions.php on line 4773

    Yes, all good questions. I’m updating Jason about that hoping he’ll share his thoughts.

    #385

    Deprecated: wp_make_content_images_responsive is deprecated since version 5.5.0! Use wp_filter_content_tags() instead. in /nfs/c09/h02/mnt/138233/domains/s2member.net/html/wp-includes/functions.php on line 4773

    Opened an issue for this too: https://github.com/websharks/s2member/issues/786

    #388
    Jason Caldwell
    Participant

    Deprecated: wp_make_content_images_responsive is deprecated since version 5.5.0! Use wp_filter_content_tags() instead. in /nfs/c09/h02/mnt/138233/domains/s2member.net/html/wp-includes/functions.php on line 4773

    Definitely looks like a Google Chrome Autofill problem to me. The yellow highlight in those fields is triggered by Autofill in Google Chrome. So you are entering and saving the details that you want, but whenever the page loads back up, the previous values are being cleared in favor of Autofill values. That’s what the yellow highlight is there to indicate—in Google Chrome.

    The other question too is why it would display one thing in my Chrome browser and not in others. In that case, which one was the actual setting that was enforced?

    Because the values that you entered and submitted are in fact being saved as expected; i.e., what you entered is what is being submitted and saved by s2Member as your configured option values. Loading that up in another browser shows what s2Member actually has. However, in Google Chrome, because you have Google Autofill enabled (which is quirky and persistent to a fault), you are seeing yellow backgrounds with autofill values. Autofilled by your browser instance only, not what s2Member actually has.

    With the autofilled (yellow background) values, if you then submit the form again (with those autofill values), you override what s2Member was supposed to have. So it can lead to confusion and bad config values.

    Unfortunately, Google Chrome Autofill is overly persistent. I’m not aware of a way to prevent this. We already set autocomplete="off on both the <form> tag and on each <input> tag. Google Chrome Autofill should be obeying those, but it’s famous for not doing so. So I suggest upgrading to the latest release of Chrome to see if that clears this up. If the problems persist, try disabling Autofill. See instructions here: https://support.google.com/chrome/answer/142893?hl=en

    #391
    Carole Asselin
    Participant

    Deprecated: wp_make_content_images_responsive is deprecated since version 5.5.0! Use wp_filter_content_tags() instead. in /nfs/c09/h02/mnt/138233/domains/s2member.net/html/wp-includes/functions.php on line 4773

    Although this might be somewhat explaining why it happens in Chrome and not in other browsers, it does not explain why it only happened when a level is skipped, while it will stick when all the levels are “used”.

    #392
    Jason Caldwell
    Participant

    Deprecated: wp_make_content_images_responsive is deprecated since version 5.5.0! Use wp_filter_content_tags() instead. in /nfs/c09/h02/mnt/138233/domains/s2member.net/html/wp-includes/functions.php on line 4773

    I imagine that has to do with the heuristic rules that are used by Google Chrome Autofill. If you’re looking for an exact reason why, I’m afraid I can’t give you that. However, I feel strongly that this is directly related to Google Chrome and whatever existing autofill values it has saved for details on that particular page—in your browser specifically.

    #393
    Carole Asselin
    Participant

    Deprecated: wp_make_content_images_responsive is deprecated since version 5.5.0! Use wp_filter_content_tags() instead. in /nfs/c09/h02/mnt/138233/domains/s2member.net/html/wp-includes/functions.php on line 4773

    Well, since i have a workaround, i am not looking for anything else, but *IF* it could have an identifiable trigger, it could be something that could either be addressed in s2M or include a warning of some kind to the s2M users so they can avoid issues since the “fix” is so simple.

    #394
    Jason Caldwell
    Participant

    Deprecated: wp_make_content_images_responsive is deprecated since version 5.5.0! Use wp_filter_content_tags() instead. in /nfs/c09/h02/mnt/138233/domains/s2member.net/html/wp-includes/functions.php on line 4773

    Copy that. I can understand frustration with this. The fix is actually quite complex; i.e., impossible in my mind at the moment. I’m not seeing a way for us to deal with this.

    As @clavaque mentioned earlier, we just contributed to a WP core fix that was similar. In that case it was something they could work around, because the field could be disabled entirely. See: https://core.trac.wordpress.org/ticket/33699

    In this case though, it looks like your browser has somehow been told to autofill values on that particular s2Member config. page. I can’t reproduce this myself, but your screencast clearly shows that being the case. What really needs to happen is for others to complain about Google Chrome Autofill not properly obeying the autocomplete="off" form attribute.

    See related discussion here: http://stackoverflow.com/questions/12374442/chrome-browser-ignoring-autocomplete-off

Viewing 18 posts - 1 through 18 (of 18 total)
  • You must be logged in to reply to this topic.